Rootserver Sponsor



Please support your operating system's further development:



Release Notes

Release Notes: aptosid 2011-03

Contributed by slh on Dec 31, 2011 - 11:58 PM

We now have the pleasure to announce the immediate availability of the final aptosid 2011-03 "Πόνος" release, shipping in the following flavours:

  • KDE-lite, amd64, en/ de, ≈590 MB.
  • KDE-lite, i686, en/ de, ≈590 MB.
  • KDE-full, amd64+i686, en/ de (cz, da, es, fr, it, ja, nl, pl, pt, pt_BR, ro, ru, uk through liveapt) ≈2.0 GB.
  • XFCE, amd64, en/ de, ≈495 MB.
  • XFCE, i686, en/ de, ≈490 MB.

aptosid is a full featured Debian sid based live CD with a special focus on hard disk installations, a clean upgrade path within sid and additional hardware and software support. The ISO is completely based on Debian sid/main, enriched and stabilised with aptosid's own packages and scripts and adhere's to the Debian Social Contract (DFSG).

Release notes for Πόνος

New features in aptosid 2011-03 "Πόνος" are in particular kernel 3.1 and numerous integration and stabilisation fixes. Special focus has been cast upon improving the system compatibility with new hardware platforms and various corner cases. Kernel 3.1 doesn't only improve and stabilise hardware support for newer devices, it also improves latency and general system performance, particularly vastly improved I/O scheduling for lvm2/ mdadm on SSDs.

Among the new features are inital XEN dom0 and PCI passthrough support as well as nested virtualization for kvm on intel and amd CPUs. The graphics arena provides improved support for Intel sandy bridge graphics (HD2000/ HD3000) and for AMD llano graphics, just like nouveau starting to provide basic support for the GeForce 4xx/ 5xx series and bringing 3d capabilities to selected chipsets. Subsystem support for DVB-T2 devices and the first devices is now available.

The networking subsystem now offers wake on wlan support (WoWLAN) and support for various new RealTek and Broadcom devices.

GPT and UEFI reliability have been improved, which allows harddisks exceeding 2 TiB and their use for booting on new systems using UEFI instead of the traditional PC-BIOS.

As usual, a large number of individual functionality enhancements and bugfixes have been applied to the full package line up and aptosid's own packages, in order to improve the general distribution infrastructure. The past months have allowed us to take special care of the small aspects in many packages, to improve general policy compliance and functionality.

We'd like to thank our sponsor Webtropia (part of myLoc managed IT AG), who provides 3 dedicated servers for our development– and hosting infrastructure and are looking forward to a lasting and successful co-operation with this fine hosting business. With the new servers from myLoc managed IT AG we are finally able to have proper technical solutions for our needs, e.g. fully separated hardware for fast kernel- and ISO-building, and an extra server for running all our other sites in virtual machines (,, etc.). All our servers are running our own server version of aptosid.

Our special thanks go to the aptosid art- and manual teams and especially and all mirror hosters for their efforts regarding aptosid.

Minimum system requirements:

  • amd64:
    • CPU requirements:
      • AMD64
      • newer 64 bit capable AMD Sempron and Intel Pentium 4 CPUs (watch for the "lm" flag in /proc/cpuinfo or use infobash -v3).
      • Intel Core2
      • Intel Atom Series (2xx/ 3xx, N4xx/ D4xx/ D5xx; the N2xx series does not support EM64T)
      • VIA Nano
      • any x86-64/ EM64T capable CPU
    • RAM requirements:
      • KDE: ≥512 MB RAM (≥1 GB RAM recommended)
      • XFCE: ≥512 MB RAM.
    • VGA graphics card capable of at least 640x480 pixel resolution.
    • optical disk drive or USB media.
    • ≥3 GB HDD space, ≥10 GB recommended.
    • supported boot methods:
      • PC-BIOS+MSDOS partition table (maximum HDD size <2 TiB)
      • PC-BIOS+GPT partition table (maximum HDD size <8 ZiB, /boot/ must physically be below 2 TiB in its entirety)
      • UEFI+GPT (maximum HDD size <8 ZiB)
  • i686:
    • CPU requirements:
      • Intel Pentium pro/ Pentium II
      • AMD K7 Athlon (not K5/ K6)
      • Intel Atom Series (Z5xx/ Z6xx, N2xx)
      • VIA C3-2 (Nehemiah, not C3 Samuel or Ezra)/ C7
      • any x86-64/ EM64T capable CPU or newer
      the full i686 instruction set is required.
    • RAM requirements:
      • KDE: ≥512 MB RAM (≥1 GB RAM recommended)
      • XFCE: ≥384 MB RAM.
      • using i686, only 3.1—3.4 GB RAM are accessible, amd64 (x86-64/ EM64T) is strongly recommended for 64 bit capable hardware.
    • VGA graphics card capable of at least 640x480 pixel resolution.
    • optical disk drive or USB media.
    • ≥3 GB HDD space, ≥10 GB recommended.
    • supported boot methods:
      • PC-BIOS+MSDOS partition table (maximum HDD size <2 TiB)
      • PC-BIOS+GPT partition table (maximum HDD size <8 ZiB, /boot/ must physically be below 2 TiB in its entirety)

Now to the interesting topics, like what's on the menu for now:

  • Debian sid, as of 2011-12-31.
  • kernel 3.1.6 (smp, hard preemption).
  • xserver-xorg-core
  • enable KMS support for ATi, Intel and nVidia based graphics chipsets.
  • DRI (3d) support for ATi Radeon chipsets up to r7xx (refer to non-free sources and Drivers).
  • KDE 4.6.5 (en + de).
  • Iceweasel 9.0.1
  • new, SVG based, art theme created by the aptosid art team.
  • offline manual for en + de directly on the disc, online manuals for more languages online at and available via apt; a big thank you goes to the documentation and translation teams!
    Please note that the offline manual is only available on the running live CD or the installed system.
  • many changes for the manual.
  • ath5k support for 54/ "108" MBit/s Atheros wlan cards (AR2425, AR5210, AR5211, AR5212, AR5213 and AR5414).
  • ath9k support for 802.11n Atheros wlan cards (AR5418+AR5133, AR5416+AR5133, AR5416+AR2133, AR9160, AR9280, AR9281 and AR9285).
  • ath9k_htc support for 802.11n Atheros USB wlan cards (AR7010/ AR9271).
  • carl9170 support for 802.11n Atheros USB wlan cards (AR9170 "otus"), now supporting HT/ aggregation and AP mode.
  • b43/ b43legacy support for Broadcom wlan cards.
    OpenFWWF 5.2 opensource firmware for the following Broadcom AirForce 802.11b/g wireless cards:
    • BCM4306
    • BCM4311 revision 1
    • BCM4318
    • BCM4320
    experimental support for LP-PHY (BCM4312) and SSB based 802.11n (BCM4321, BCM4322) devices, non-free firmware images required.
  • iwlagn support for IPW 3945/ 4965 and the IEEE 802.11 a/b/g/n part of the Intel Wireless WiFi Link 1000/ 2000/ 5xxxAGN/ 6000/ 6050 family.
  • iwmc3200wifi support for Intel Wireless Multicomm 802.11.
  • rt2x00 support for RaLink rt2400, rt2500, rt2570, rt61 and rt73 802.11b/g cards.
  • support for RaLink rt27x0, rt28x0, rt30x0, rt33xx, rt35xx, rt53xx 802.11b/g/n PCI/ USB cards through rt2x00.
  • support for RealTek RTL8180L/ RTL8185 PCI/ cardbus and RTL8187/ RTL8187B USB wlan cards.
  • support for RealTek RTL8188CE/ RTL8192CE, RTL8188DE/ RTL8192DE, RTL8188SE/ RTL8192SE (PCIe) and RTL8188CU/ RTL8192CU (USB) 802.11n wlan cards.
  • memtest86+.
  • OpenJDK 6 as part of the kde-full variant.
  • support kvm (Kernel-based Virtual Machine) for kde-full; kvm depends on hardware virtualisation support (AMD pacifica virtualisation extensions "svm" or Intel IVT (vanderpool) virtualisation extensions "vmx")
  • access point support for many mac80211 based wlan cards through nl80211 and hostapd (optional).
  • client support for network booting over PXE/ NBD.
  • re-add usbutils.
  • make sure that polkit-kde-1 is available on KDE builds.
  • support for multi-tuner DVB cards.
  • fix gpm (tty mouse support) for kernel 3.x.
  • transition from /var/run/ to /run/, /var/lock/ to /run/lock/ and /lib/init/rw/ to /run/.
  • replace separate mtab handling by using /proc/mounts directly.
  • stability and compatibility improvements for USB and system installer.
  • fixes for ext4 backed persistency.
  • employ KDE's "Air theme".
  • provide easy UEFI detection.
  • install iw to configure mac80211/ cfg80211 based wlan cards on default.
  • simplify and fix md5sum cheatcode on the live media.
  • make dmakms handling more robust.
  • fix broken DHCP configuration, which tends to overwrite the configured hostname.
  • adapt nbd based booting/ installation options to upstream changes.
  • welcome Ukrainian to the list of supported languages.

Frequently asked questions


It is recommended to set keymaps, locales and timezone before booting the live system to be installed, by selecting them from the boot menu [F2], [F3]. This way, locale settings propagate to all required places for the installed system and don't require cumbersome changes at several places.

Kernel based Mode Setting (KMS) and intel/ nvidia/ radeon graphics

KMS support is required by xserver-xorg-video-intel, which means kernel parameters like "i915.modeset=0" or "vga=791" are no longer valid and actively break starting X on intel graphics cards. Given that i915/ xserver-xorg-video-intel doesn't require any kind of firmware, there should no longer be KMS related bugs in relation to intel graphics.

For KMS to function in combination with ATi/ AMD radeon graphics, firmware images (firmware-linux-nonfree, see below) are required, which can't be shipped on aptosid live media, while should transparently fall back to vesa on problematic cards, special attention might be needed in rare cases. If X doesn't manage to start on ATi/ AMD radeon graphics cards, it might help to supply "radeon.modeset=0" as boot option for the live CD and to install the required firmware package "firmware-linux-nonfree" on the live system, before installing to the harddisk. Once firmware-linux-nonfree is installed, kernel parameters like "radeon.modeset=0" or "vga=791" should not be used anymore, as they might interfere with KMS operations, which are needed for radeon to work properly.

Nouveau doesn't require any kind of firmware and supports KMS natively, framebuffer kernel parameters like "vga=791" are no longer valid and break starting X on nVidia graphics cards.


While grub2 offers increased flexibility for installations, like UEFI support (optional), new filesystems (ext4) or advanced installation options like software RAID (mdadm), LVM2 and improved detection capabilities for other distributions and operating systems, it is limited to a textmode menu. A new theming effort is currently under development and may become available in the future. Even though support for plain wallpapers would be already supported by grub2, it is still fragile and prolongs the system boot. Internally the configuration system for grub2 uses scripts snippets under /etc/grub.d/ to create its configuration file "grub.cfg" in a way that allows many self updating features, such as automating fromiso support with the help of "grub2-fll-fromiso" (optional).


With isolinux supporting gfxboot, it is possible to use isohybrid, which allows writing an ISO directly to USB storage or sd/ sdhc/ mmc memory sticks to make these bootable. isohybrid adds an MBR to the ISO and sets up a partition table with one active entry, the partition containing the ISO. This allows writing aptosid ISOs directly to USB storage devices of sdhc memory cards in addition to the well known possibility of using "install-aptosid-to-usb" (install-usb-gui). This option is particularly useful if there is no existing aptosid installation available and if an installation medium needs to be created from another distribution or operating system. It is important to note that this method overwrites the whole USB medium and restricts the available storage to the size of the aptosid ISO; install-usb-gui is not subject to these limitations and therefore the recommended option in case an existing aptosid system is available. Further partitions can be added to allow access to the unused part of the storage device.

$ cat /path/to/aptosid-*.iso > /dev/usb_raw_device_node

Further information about the aptosid install is available from the aptosid manual at Installation options.

Wireless regulatory domain settings

The regulatory domain framework for cfg80211 based wlan cards requires crda to allow access to wireless channels above ch11 (2.4 GHz or their 5 GHz equivalents), without crda only the "world domain" (channel 1-11) is available.

# apt-get update
# apt-get install crda

Network booting aptosid

Network booting aptosid over PXE (Preboot Execution Environment) and NBD (Network Block Device) is supported, the required settings can be configured from within the boot menu [F4]. Instructions about how to set up an example PXE+NBD boot server can be obtained at aptosid netboot introduction.

UEFI booting

Preliminary support for booting with UEFI has been added to the amd64 editions for aptosid 2011-03 "Πόνος". While the installer GUI has not been finalised yet, the bootloader will be an EFI program installed to /efi/aptosid within your "EFI system partition" and mounted below /boot/efi/ on your installed system, provided the following conditions are met:

  • x86-64/ EM64T system (amd64).
  • booted using UEFI, this is apparent from the plain white/blue grub2 menu, instead of the usual graphical boot menu provided by isolinux for BIOS booting, on the live medium.
  • a vfat formatted EFI system partition on a GPT disk (type EF00) exists on the target system.
  • the install target is not a USB disk.

At the moment aptosid only offers UEFI booting for its 64 bit edition (amd64), 32 bit UEFI (such as older Apple systems) is currently not supported. Multiboot with other 64 bit operating systems should be possible, but could not be tested yet.

UEFI bootable removable devices

In order to create a UEFI bootable device, such as a USB stick, the contents of the aptosid ISO can be extracted to a vfat formatted partition and the partition marked as bootable. Optionally this removable medium can also be made compatible with PC-BIOS booting by installing a traditional bootsector in addition to the EFI bootloader (assuming /dev/sdz1 to be the target partition on the USB stick).

syslinux -i -d /boot/isolinux /dev/sdz1
install-mbr /dev/sdz


A special feature of kde-full releases is the ability to select other languages than German or US English from the boot menu (F2), which automatically installs localisations for the desktop and many applications while booting. This ensures they are also present after installing aptosid, while only installing the required languages for the given system. The amount of memory required for this feature depends on the language and aptosid may refuse to install the given language packs automatically with insufficient RAM and the boot sequence will be continued in english language but with the desired locales-settings (currency, date/ time format, keyboard charsets). 1 GB memory or more is supposed to be safe for all supported languages, which are:

  • Czech
  • Danish
  • Dutch
  • English (GB, US, AU)
  • French
  • German
  • Italian
  • Japanese
  • Polish
  • Portuguese (BR, PT)
  • Romanian
  • Russian
  • Spanish
  • Ukrainian

The language selection depends on the availability of aptosid-manual translations, get involved to add your language. Levels of up-to-date translation completeness of the following languages has dropped below the quorum for inclusion at this moment:

  • Bulgarian
  • Croatian
  • French
  • Greek
  • Hungarian

Additional help is urgently needed for these languages, before their translation status degrades too much.

Hints for Upgraders:

aptosid tries hard to provide seamless upgrade path for debian and aptosid's own packages, nevertheless a few things remain that could be improved with manual interaction.


xserver-xorg-video-nv has been removed from Debian, which means xserver-xorg-video-nouveau now takes its place. Therefore we recommend users of nvidia graphics cards to purge xserver-xorg-video-nv, and install xserver-xorg-video-nouveau; configuration changes should not be required. On selected chipset generations, basic video and 3d acceleration is available through xserver-xorg-video-nouveau and libgl1-mesa-dri-experimental.

# apt-get install xserver-xorg-video-nouveau libgl1-mesa-dri-experimental

KDE 4.6 and XFCE 4.8

Upgrading to KDE 4.6 or XFCE 4.8 might not pull all required packages in certain corner cases, please make sure to install them manually. Without these packages, powermanagement, mounting of removable media and applying system wide configuration changes in systemsettings only work partially.

# apt-get install polkit-kde-1 udisks upower

Obsolete packages

As part of the continuing development of aptosid, a number of packages have been replaced by better alternatives or become redundant.

  • kaboom
    Transitional helper for KDE3 → KDE4 migrations of user configuration, which can be removed after the successful migration.
  • modconf
    This package has been removed from Debian after "squeeze" and doesn't serve any real purpose these days.

Transitional packages and obsolete libraries can often be identified by "deborphan". While this tool is very convenient for ongoing system cleanup, its results should always be checked before using it as input for removals.

$ deborphan

The following command is able to find packages not available from any active apt repository and may hint at obsolete packages, be careful about manually installed packages though. apt-show-versions is a separate package and isn't necessarily preinstalled. Before using apt-show-versions, it is absolutely mandatory to fully dist-upgrade the system and carefully check manually installed packages.

$ apt-show-versions | awk '/No available version in archive/{print $1}'


This is experimental software. Use at your own risk. The aptosid project, it's developers and team members cannot be held liable under any circumstances for damage to hardware or software, lost data, or other direct or indirect damage resulting from the use of this software. If you do not agree to these terms and conditions, you should not use or distribute this software.

How to get involved

Getting involved in aptosid is easy, just join us at our Forum or even better on IRC (, port 6667, channel #aptosid) and discuss your patches/ proposals or additions.

We will gladly discuss any dfsg-free patches and contributions, especially regarding alternative window managers (GNOME, LXDE), general cleanup tasks or translations/ localisations.


Please understand that the following roadmap is a rough estimate regarding our release schedule and is affected by the status of upstream Debian sid, major system components like, KDE, the linux kernel and our own developments and is subject to changes.

  • Θάνατος
  • Ἑσπερίδες
  • Νέμεσις
  • Φιλότης

Special thanks go to the entire aptosid team.


Rick Battle (detaos)
Joaquim Boura (x-un-i)
Roland Engert (RoEn)
Chris Hildebrandt (slam)
David Kalnischkies (DonKult)
Aedan Kelly (etorix)
Stefan Lippers-Hollmann (slh)
Kel Modderman (kelmo)
Trevor Walkley (bluewater)
Niall Walsh (bfree)

Documentation and Manuals:

Joaquim Boura (x-un-i)
Alpha Mohamed Diakite (alphad)
Stefan R. Eissens (eislon)
Roland Engert (RoEn)
Alessio Giustini (alessiog75)
Markus Huber (hubi)
Pavlo Libovych (polix)
Janusz Martyniak (wiarus_old)
Mutsumu Nomura (muchan)
Rasmus Güllich Pørksen (ragupo)
Dawid Staropietka (DaVidoSS)
Bruno Torremans (btorrem)
Robert Ulatowski (quidam77)
Dorin Vatavu (dorin)
Bram Verdoodt (Bram0s)
Petr Vorel (pumrel)
Trevor Walkley (bluewater)

Art Team:

Rick Battle (detaos)

Web design Team:

Chris Hildebrandt (slam)
Stefan Lippers-Hollmann (slh)

Vital Support:

Chris Hildebrandt (slam)
Ralph Hokanson Jr. (piper)
Markus Huber (hubi)
David Kalnischkies (DonKult)
Mutsumu Nomura (muchan)

Thanks to for sponsoring

On behalf of the aptosid team:
        Stefan Lippers-Hollmann (slh)