Rootserver Sponsor

webtropia"

Donations

Please support your operating system's further development:

donate"

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
debabaOffline
Post subject: [Solved] slow startup  PostPosted: 10.03.2018, 08:17



Joined: 2010-09-11
Posts: 54
Location: Hessen
Status: Offline
Hi,
i got a problem with System startup. The loading of the kernel takes very long (1 min and 33s). That's not normal for an ssd-device. After kernel-load userspace is done in 10s.
      Code:
schindler@phenom:~$ systemd-analyze
Startup finished in 1min 33.526s (kernel) + 10.298s (userspace) = 1min 43.824s
graphical.target reached after 10.285s in userspace

      Code:
schindler@phenom:~$ systemd-analyze blame
          6.877s NetworkManager-wait-online.service
          2.207s home-daten-musik.mount
          1.585s exim4.service
          1.091s udisks2.service
          1.008s vboxdrv.service
           983ms networking.service
           958ms mariadb.service
           839ms dev-sdc3.device
           536ms ufw.service
           498ms systemd-journal-flush.service
           437ms NetworkManager.service
           364ms colord.service
           334ms loadcpufreq.service
           312ms systemd-udev-trigger.service
           309ms keyboard-setup.service
           308ms fancontrol.service
           303ms sensord.service
           290ms accounts-daemon.service
           275ms cpufreqd.service
           248ms gdomap.service
           244ms systemd-remount-fs.service
           243ms kmod-static-nodes.service
           237ms gpm.service
           236ms run-rpc_pipefs.mount
           234ms systemd-modules-load.service
           220ms dev-hugepages.mount
           208ms systemd-logind.service
......

There are no special signs in startup log except:
      Code:
Mär 09 16:39:13 phenom kernel: Hierarchical SRCU implementation.
Mär 09 16:39:13 phenom kernel: smp: Bringing up secondary CPUs ...
Mär 09 16:39:13 phenom kernel: x86: Booting SMP configuration:
Mär 09 16:39:13 phenom kernel: .... node  #0, CPUs:      #1
Mär 09 16:39:13 phenom kernel: do_IRQ: 1.55 No irq handler for vector
Mär 09 16:39:13 phenom kernel: process: Switch to broadcast mode on CPU1
Mär 09 16:39:13 phenom kernel:  #2
Mär 09 16:39:13 phenom kernel: do_IRQ: 2.55 No irq handler for vector
Mär 09 16:39:13 phenom kernel: process: Switch to broadcast mode on CPU2
Mär 09 16:39:13 phenom kernel:  #3
Mär 09 16:39:13 phenom kernel: do_IRQ: 3.55 No irq handler for vector
Mär 09 16:39:13 phenom kernel: process: Switch to broadcast mode on CPU3
Mär 09 16:39:13 phenom kernel: smp: Brought up 1 node, 4 CPUs
Mär 09 16:39:13 phenom kernel: smpboot: Max logical packages: 2
Mär 09 16:39:13 phenom kernel: smpboot: Total of 4 processors activated (27320.81 BogoMIPS)

and
      Code:
Mär 09 16:39:13 phenom kernel: ACPI: Added _OSI(Processor Aggregator Device)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKC (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKD (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKB (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKD (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKB (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKC (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKB (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKC (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKD (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKB (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKC (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKD (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKC (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKD (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKB (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKD (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKB (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKC (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKB (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKC (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKD (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKB (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKC (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKD (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKC (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKD (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKB (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKD (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKB (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKC (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKB (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKC (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI Exception: Could not find/resolve named package element: LNKD (20170831/dspkginit-381)
Mär 09 16:39:13 phenom kernel: ACPI: Interpreter enabled
Mär 09 16:39:13 phenom kernel: ACPI: (supports S0 S3 S4 S5)

the big waiting happens here:
      Code:
Mar  9 16:39:14 phenom kernel: [    3.858163] sd 7:0:0:0: [sdb] Attached SCSI removable disk
Mar  9 16:39:14 phenom kernel: [    3.899670]  sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 >
Mar  9 16:39:14 phenom kernel: [    3.900149] sd 4:0:0:0: [sda] Attached SCSI removable disk
Mar  9 16:39:14 phenom kernel: [    3.983179] sr 9:0:0:0: [sr0] scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
Mar  9 16:39:14 phenom kernel: [    3.983181] cdrom: Uniform CD-ROM driver Revision: 3.20
Mar  9 16:39:14 phenom kernel: [    3.983308] sr 9:0:0:0: Attached scsi CD-ROM sr0
Mar  9 16:39:14 phenom kernel: [    4.043123] ata12.00: disabling queued TRIM support
Mar  9 16:39:14 phenom kernel: [    4.052489] ata12.00: configured for UDMA/133
Mar  9 16:39:14 phenom kernel: [    4.060565] scsi 11:0:0:0: Direct-Access     ATA      Samsung SSD 850  2B6Q PQ: 0 ANSI: 5
Mar  9 16:39:14 phenom kernel: [    4.068914] sd 11:0:0:0: [sdc] 976773168 512-byte logical blocks: (500 GB/466 GiB)
Mar  9 16:39:14 phenom kernel: [    4.069189] scsi 17:0:0:0: Processor         Marvell  91xx Config      1.01 PQ: 0 ANSI: 5
Mar  9 16:39:14 phenom kernel: [    4.085194] sd 11:0:0:0: [sdc] Write Protect is off
Mar  9 16:39:14 phenom kernel: [    4.093116] sd 11:0:0:0: [sdc] Mode Sense: 00 3a 00 00
Mar  9 16:39:14 phenom kernel: [    4.100810] sd 11:0:0:0: [sdc] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Mar  9 16:39:14 phenom kernel: [    4.109951]  sdc: sdc1 sdc2 sdc3 sdc4
Mar  9 16:39:14 phenom kernel: [    4.117859] sd 11:0:0:0: [sdc] supports TCG Opal
Mar  9 16:39:14 phenom kernel: [    4.125042] sd 11:0:0:0: [sdc] Attached SCSI disk
Mar  9 16:39:14 phenom kernel: [    4.272478] random: crng init done
Mar  9 16:39:14 phenom kernel: [   92.926018] raid6: sse2x1   gen()  4644 MB/s
Mar  9 16:39:14 phenom kernel: [   92.949009] raid6: sse2x1   xor()  4496 MB/s
Mar  9 16:39:14 phenom kernel: [   92.972018] raid6: sse2x2   gen()  7250 MB/s
Mar  9 16:39:14 phenom kernel: [   92.995006] raid6: sse2x2   xor()  7718 MB/s
Mar  9 16:39:14 phenom kernel: [   93.018013] raid6: sse2x4   gen()  8535 MB/s
Mar  9 16:39:14 phenom kernel: [   93.041012] raid6: sse2x4   xor()  3835 MB/s
Mar  9 16:39:14 phenom kernel: [   93.047030] raid6: using algorithm sse2x4 gen() 8535 MB/s
Mar  9 16:39:14 phenom kernel: [   93.053143] raid6: .... xor() 3835 MB/s, rmw enabled
Mar  9 16:39:14 phenom kernel: [   93.059228] raid6: using intx1 recovery algorithm
Mar  9 16:39:14 phenom kernel: [   93.065496] xor: measuring software checksum speed
Mar  9 16:39:14 phenom kernel: [   93.081011]    prefetch64-sse: 13440.000 MB/sec
Mar  9 16:39:14 phenom kernel: [   93.097007]    generic_sse: 12772.000 MB/sec
Mar  9 16:39:14 phenom kernel: [   93.103266] xor: using function: prefetch64-sse (13440.000 MB/sec)
Mar  9 16:39:14 phenom kernel: [   93.109872] async_tx: api initialized (async)
Mar  9 16:39:14 phenom kernel: [   93.148804] Btrfs loaded, crc32c=crc32c-generic


I saw in Finotti's (keyboard/mouse) post, that he also got rather big waiting times.
Tried disconnecting all USB Stuff, even disabled some modules (btrfs, raid456, etc) no change.

Saw this behavior some days before the first time after upgrading and subsequently fscking of the system-partition.

Thanks for some help how to check out what the problem could be or how to finish it.
 
 View user's profile Send private message  
Reply with quote Back to top
debabaOffline
Post subject: RE: [Solved] slow startup  PostPosted: 10.03.2018, 13:21



Joined: 2010-09-11
Posts: 54
Location: Hessen
Status: Offline
After switch off and taking the machine physically from power, to not be harmed by a thunderstorm, the machine started like always.

Excuse for the hot wind
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: [Solved] slow startup  PostPosted: 10.03.2018, 21:35



Joined: 2010-08-25
Posts: 954

Status: Offline
It's not normal (it doesn't happen on any of my systems), but could happen if a device fails to initialize correctly.
If it happens again, please post a full dmesg.
 
 View user's profile Send private message  
Reply with quote Back to top
debabaOffline
Post subject: RE: [Solved] slow startup  PostPosted: 11.03.2018, 08:03



Joined: 2010-09-11
Posts: 54
Location: Hessen
Status: Offline
You're right.
It was the AMD HD5870 Graphicscard with radeon driver.
I remember, i had a sentimental day with trying old stuff, for example crunching for boinc, One of the Einstein@home compute units crashed. So a hard reset via reset button was necessary. Seems it left the graphic card in undetermined state that was just reinitialized after the complete power off and a wait for emptying all condensators. Tried again today, same reaction. Interestingly the OpenCL-crunching-units from Collatz were running without problems.
This OpenCL stuff on Mesa is not as stable as it is thought, or the units expect old ATI APP Stuff as OpenCL. Don't know exactly. Decided to not heat up our atmosphere any more, so we don't need crunching for external intelligence or which Asteroid can be settled.

Have a nice day
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio